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Useful Links

MOST IMORTANT — Learning OpenCV Book!

Get your hands on a “Learning OpenCV” book. This book has a lot of info and
hints/tips on programming with OpenCV. It explains some theory as well.
http://oreilly.com/catalog/9780596516130/

Visual Studio and other Microsoft Products Free Download
Link: http://msdn.cs.auckland.ac.nz/

Recommended downloads:
e Visual Studio 2008
e MSDN (if you have a lot of space as it is available online)

IMPORTANT NOTE: Use the same version of Visual Studio when editing your
programs! If you switch between Visual Studio 2005 and 2008, then you may get
bugs and your code will not work. It can take a while to figure it out. You have been
warned.

OpenCV (Open Computer Vision Library)

Link to download for Windows:
http://sourceforge.net/projects/opencvlibrary/

Link to Official Website:
http://www.intel.com/technology/computing/opencv/index.htm

Link for “cheat sheet” and introduction to OpenCV:
http://www.cs.iit.edu/~agam/cs512/lect-notes/opencv-intro/opencv-intro.html

Wiki for documentation on OpenCV:
http://opencvlibrary.sourceforge.net/

OpenCV Reference Manual:
http://www.cs.unc.edu/Research/stc/FAQs/OpenCV/OpenCVReferenceManual.pdf

OpenCV User Group:
http://groups.yahoo.com/group/OpenCV/

Other Possibly Useful Links

IPP (Intel Performance Primatives):
http://www.intel.com/cd/software/products/asmo-na/eng/302910.htm

Only recommended for the people who are very keen. This is a library that will be
used by OpenCV if it is installed. It is a library that optimises your processor for
running Computer Vision mathematics. l.e. it will speed up your programs when you
run them.
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Getting OpenCV Working on your PC

First you need to get a copy of Visual Studio 2008.
Secondly, you need to install OpenCV.

(See page 1 for links.)

Now you are ready, but there are some minor things that need to be set up.

IMPORTANT NOTE:

where “C:\Program Files\OpenCV” is used in this setup, make sure that this is the
location where OpenCV is installed.

For Computer Science Students:
On all Science Lab machines, OpenCV is installed under the default path, i.e.
“C:\Program Files\OpenCV”

For Mechanical Engineering Students:
OpenCV is installed under the MECHENG409 folder, i.e.
“S:\Mech\Courses\MechEng409\OpenCV”

Create New Project

« Within Developer Studio create new application:
o Select from menu "File"->"New..."->"Projects" tab.
e Choose "Visual C++” > “Win32” > “Console Application”.

New Project

Project types: Templates: I MET Framework 3.5

Reporting ;I Visual Studio installed templates
Test .
VICF Win32 Console Application 3 Win32 Project
Workflow

Visual C# My Templates

Visual C++ - search Online Templates. ..
ATL
CLR
General
MFC
Smart Device
Test
Win32

Other Project Types

Test Projects —

-

A project for creating a Win32 console application

Mame: I <Enter_name >

Location:

| H: \Wisual Studio 2008 \Projects

Solution:

ICreate new Solution

j ¥ Create directory for solution

Solution Name: | <Enter_name

j Browse... |

o]

Cancel
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e Type the project name and choose location
o Click OK..
o Inthe Application Wizard, click Next.

Win32 Application Wizard - Test 21X

Welcome to the Win32 Application Wizard

Creerview These are the current project settings:

Application Settings + Console application
Click Finish from any window to accept the current settings.

After you create the project, see the project’s readme. txt file for information
about the project features and files that are generated.

Next I Finish | Cancel

< Previous

e | recommend unchecking “Precompiled headers”
e Then click Finish.

Win32 Application Wizard - Test 2x|
Application Settings

Overview Application type: Add common header files for:
Application Settings (" Windows application [~ an

o ] ™ wFc

DL

"~ Static library

Additional options:

I~ Empty project

= | Export symbols

¥ Precompiled header

< Previous Next = Finish Cancel
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After the above steps done Developer Studio will create the project folder (by
default it has the same name as the project), <project name>.vcproj file,
Solution <project name>.sIn and, Three Source files: <project name>.cpp,
stdafx.cpp and stdafx.h. StdAfx files are precompiled header files, which |
find cause more pain than they’re worth.

For example, consider that we have created a new "Hello™ Project. Open the
Hello.cpp file, and include the OpenCV-related #include directives:

#include <cv.h>
#include <cxcore.h>
#include <highgui.h>

Note that these should be included after stdafx.h (if using pre-compiled
headers) or you may get build errors.

Now type some OpenCV code, and Build the Solution by pressing the F7 Key.
There should be linker errors. E.g.

Ipllmage * src = cvLoadlmage('picture.bmp™,1);

To resolve these, add dependency projects into workspace (following steps)
Choose from menu: "Project” -> "Properties”. (Or right click on your project
in the left hand tree)

Choose “Configuration Properties” -> "Linker" tab -> "Input" category ->
"Additional Dependencies:"

Add the paths for all necessary import libraries (cxcore.lib cv.lib highgui.lib
cvaux.lib)

Configuration: IAcﬁve(Debug) j Platform: IAcﬁve[\"a'inH) j Configuration Manager... |
Configuration Properties ;I Additional Dependencies cxcoreldib cv.lib highguilib cvaux.lib cwcam.lib J
General Ignore All Default Libraries Mo
Debugging Ignore Spedific Library
C/c++ Module Definition File
General Add Madule to Assembly
Optimization Embed Managed Resource File
Prepracessar ) Force Symbol References
LCode Generation Delay Loaded DLLs
P?Z?:r:g;ed Headers Assembly Link Resource
Output Files
Browse Information
Advanced
Command Line
Linker
General
Input
Manifest File
Debugging
System —
Optimization
Embedded IDL
Advanced Additional Dependencies
Command Line - Spedfies additional items to add to the link line (ex: kernel32.lib); configuration spedfic.
J o

oK I Cancel Apply
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OPTION 1: Customize Project Options

NOTE: If you do NOT do this, you will NEED to do OPTION 2.

PROS:
- Can copy the project and run from anywhere as long as the paths are the same.
- Perfect for the Lab PC’s

CONS:
- Needs to be set up on every new project you create.

e Choose from menu: "Project™ -> "Properties”. (Or right click on your project
in the left hand tree)

o Choose "Linker" tab -> "General" category -> "Additional Library
Directories”, Add the paths:

"C:\Program Files\OpenCV\lib"

Configuration: IAcﬁ\re(Dehug) j Platform: IAcﬁve[\“a'in32) j Configuration Manager... |
Configuration Properties ;I Qutput File s(0outDir) \${ProjectiMame).exe
General Show Progress Not Set
Debugging Version
ClC++ Enable Incremental Linking Yes (JINCREMENTAL)
General Suppress Startup Banner Yes (/NOLOGQ)
Optimization Ignore Import Library Mo
Preprocessor i Register Output Mo
Code Generation Per-user Redirection MNa
Il;fgcg;:ﬁﬁed Headers .u:Iu:Iiﬁ-:unaI Library IZ:IirEE-:urir:s “Ct'\Program Files\OpenCVYib™ J
Cutput Files Link Library Dependendes Yes
Browee Information Use Library Dependency Inputs Mo
Advanced Use UNICODE Response Files Yes
Command Line
Linker
General
Input
Manifest File
Diebugging
System —
Optimization
Embedded IDL
Advanced Additional Library Directories

delimited list if more than one.  {LIBPATH: [dir])

Command Line - Spedifies one or more additional paths to search for libraries; configuration specific; use semi-colon
| |

oK I Cancel | Apply

e Now, choose "C\C++" -> "General" -> "Additional Include Directories”

"C:\Program Files\OpenCV\cv\include"
"C:\Program Files\OpenCV\cxcore\include"
"C:\Program Files\OpenCV\otherlibs\highgui"
"C:\Program Files\OpenCV\cvaux\include"
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Configuration: IAcﬁ\re(Dehug)

Configuration Properties

General

Debugging

C/C++
General
Optimization
Preprocessor
Code Generation
Language
Precompiled Headers
Qutput Files
Browse Information
Advanced
Command Line

Linker
General
Input
Manifest File
Diebugging
System
Optimization
Embedded IDL
Advanced

=

Command Line -
| |

j Platform: IAcﬁ\re (Win32)

Additional Indude Directories

Resolve #using References
Debug Information Farmat
Suppress Startup Banner
Warning Level

Detect 64-bit Portability Issues
Treat Warnings As Errors

Use UNICODE Responze Files

j Configuration Manager... |

"C:\Program Files\0penCV\occore\includ e";"C:\F“I

Program Database for Edit & Continue (/ZI)
Yes {fnologa)

Level 3 (fW3)

Mo

Mo

es

Additional Include Directories
Spedifies one or more directories to add to the incude path; use semi-colon delimited list if more than one.

(1[path])

oK I Cancel Apply

Click OK to save your settings.
That’s it, you should be able to compile and run your code ©

OPTION 2: Customize Global Options

NOTE: If you do NOT do this, you will NEED to do OPTION 1.

PROS:

Every project that is set up will work straight away.
Perfect for home PC’s

CONS:

Will not work very well on Lab PC’s.

Open the Visual C++ Application. In the menu bar, select Tools->Options
In the listing, choose Projects and Solutions -> VC++ Directories.

First, select Library files from the "Show Directories for™ List Box.
Click the Insert New icon, and locate the folder where you have installed

opencyv.

Consider that it is installed in "C:/Program Files/OpenCV".

In the Library files list, locate and add:

"C:\Program Files\OpenCV\lib"
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Platform: Show directories for:

Environment

Projects and Solutions IWin32 j Library files
General
Build and Run
VB Defaults
) : C:'\Program Files\OpenCViib
Uil HISE I S{VCInstallDir)lib
VC++ Project Settings S{VCInstallDir)atimfcib
Source Control &(VCInstallDirJatimfcyibyi386
Text Editar S{windowsSdkDir) Yib
&(FrameworkSDKDIr)lib
Da’ﬁba;e Tools S(VSInstaliDir)
Debugging s(vsInstallDir)lib
Device Tools

HTML Designer -
Office Tools ] | | »
Test Tools

Library Directories

Text Templatin
Window I; gD ) Path to use when searching for library files while building a VC++ project. ;I
indaws Farms Liesigner Corresponds to environment variable LIB. LI

Workflow Designer
oK I Cancel |

« Now choose Include files in the list box, and locate and add the following
directories:

"C:\Program Files\OpenCV\cv\include"
"C:\Program Files\OpenCV\cxcore\include"
"C:\Program Files\OpenCV\otherlibs\highgui"
"C:\Program Files\OpenCV\cvaux\include"

CEEE——— (x|

Environment Platform: Show directories for:
Projects and Solutions IWin32 j IIndude files j
General
Build and Run ,/ll‘jil }(l +| fl
VB Defaults ; E thort
" . ‘rogram Fi =1 =11l = -
Lilamr D|re.ctorles . C:\Program Files\OpenCVicvauxndude —
VC++ Project Settings C:'Program Files\OpenCViotherlibshighgui
Source Control C:VProgram Files\OpenCVioocorelindude™
Text Editor C:'Program Files\OpenCVicviindude
&(VCInstallDirjindude
Database Tools &(VCInstalDir)atmfjinclude
Debugging S(WindowsSdkDir)indude
Device Tools &(FrameworkSDKDirjindude [
HTML Designier -
Office Tools 4| | .
Test Tools — =
Text Templatin Include Directories
Window ’p: gD ) Path to use when searching for indude files while building a VC ++ project. :I
indows Forms Lesigner Carresponds to environmeant variable INCLUDE.
Waorkflow Designer LI

oK I Cancel |
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o Next, choose source files in the list box, and locate and add the following
directories:

"C:\Program Files\OpenCV\cv\src"
"C:\Program Files\OpenCV\cxcore\src"
"C:\Program Files\OpenCV\cvaux\src"
"C:\Program Files\OpenCV\otherlibs\highgui”

options 21

Environment Platform: Show directories for:
Projects and Solutions IWin32 j ISuurce files j

General

Build and Run ,/ll‘jil }(l +| fl

VE Defaults i

) . ram File:

Lilamr D|re.ctorles . C:'Program Files\OpenCVio Yhig

VC++ Project Settings C:'Program Files\OpenCVicvaux\sre
Source Control C:VProgram Files\OpenCVicxcoresrc
Text Editor CE\-'IIPFDQFEIIT Fizllesﬂ'l,Of?:nla;lC}I:ﬂ'l,cf\é'lsrc

S(VCInstallDirjatimfc\src
Database Tools ${VCnstalDir)atimf\src\mfcm
Debuaging s(VCInstallDir)atimfc\srcat
Device Tools S(VCInstallDir)crtlsrc .
HTML Designier -
Office Tools 4| | .
Test Tools . .
Text Templatin Source Directories
) Patng ) Path to use when searching for source files to use for Intellisense. :I

Windows Forms Designer
Waorkflow Designer LI

e Now click OK in the Options dialog.
« You have successfully configured the global settings.
e That’s it, you should be able to compile and run your code ©

Final notes

If you have any issues, double check the steps above.

Also look at the other resources available on the net.
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Common Problems

Missing DLL'’s

You may get the following error message if the PATH has not been set for OpenCV.

MedFilterOpticalFlowDemo.exe - Unable To Locate Component

@ This application has failed to start because cxcarel00.dll was not Found. Re-installing the application may Fix this problen,

To fix this there are some different options:

1.

If you do not have admin rights to the computer, or you are using a “hotseat”
computer, i.e. you can use multiple computers but log into your profile.
Then the best solution is to copy and paste the required *.DLL files from
.\OpenCV\bin to your ..\<MSVisProj>\ folder (i.e., where your project files
are).

If you have admin rights on the computer, then you can also update your
PATH directory: to change your PATH settings, right-click 'My Computer’,
click 'Properties' and look at the ‘Advanced' tab. There you will see a button
marked 'Environment Variables' - click it. In the window that then appears,
look for the PATH option in the lower list of the two presented. Add
“.\OpenCV\bin\” as the last entry in PATH, usually separated using a
semicolon (;).

If 2 does not work, then simply copy all the *.DLL files from ..\OpenCV\bin
to C:\WINDOWS\system32. Or follow the option 1 above.
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