Notepad++

The COMPSCI 101 Text Editor for Windows

The text editor that we will be using in the Computer Science

labs for creating our Python programs is called Notepad++and  http://notepad-plus-plus.org
is freely available for the Windows operating system. If you

plan to do work outside of the labs, perhaps at home, you may

like to use the same software that we have available in the labs. This document describes how to
install and configure Notepad++ using the same settings available in the labs.

What is a text editor?

A text editor is a program that enables you to write plain text files (a text file is a file that consists of
lines of text comprised mainly of the characters that you can type on a keyboard). A common
extension for text files is .txt, although the Python source files that we are creating in this course are
also examples of text files and use the extension .py. There are many text editors that are freely
available for you to use. For example, Windows provides a very simple text editor called Notepad
(that you can find under the Accessories menu). However, this is not a very good editor for writing
source code because it doesn’t support useful features such as syntax-colouring, auto-indentation
and brace highlighting. Notepad++ is a freely available text editor for Windows, and is the editor we
will be using in the labs to write our Java source code.

Install Python 3

Before installing and configuring L T s o
Notepad++ make Sure that M H#E¥ Google 105Stuffv 10linfo~ Unixinfo~ Py D;n;”ymn :Ymmmg v FunStuff v AdminUoA ¥ AdminCS~ Personal v :)
you have installed Python 3.

You can doyvnload and install the most ‘. pgthOﬂm
recent version from:

About Downloads Documentation Community Success Stories News Events

. Download the latest version for Mac OS X )
https://www.python.org/downloads/windows [
}

Wondering which version to use? Here’s more about the difference between Python
2and 3.

Looking for Python with a different 0S? Python for Windows, Linux/UNIX, Mac OS X,

Make sure you are downloading other

Python 3.

Want to help test development versions of Python? Pre-releases

Looking for a specific release?

Python releases by version number:
Release version Release date Click for more
Python 2.7.10 2015-05-23 & Download

Python 3.4.3 2015-02-25 & Download

Installing Notepad++

Start by browsing to the main NotePad++ website:
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http://notepad-plus-plus.org

From here, you can select the Download menu, and
download the Notepad++ installer:

Protect your |
MacKee

Double-click the installer (the .exe file which you downloaded) and simply follow the prompts,
accepting the default options.

To check that you have installed Notepad++ correctly, run the application and you should see an
editor window like the following appear:

File Edit Search View Encoding Language Settings Macro Run Plugins Window 2
HEE 4R ECne s EBES1ECEL DD EER
lanevnl
T Console a)
Your console window may
< be along the bottom of the
‘]i window (it is shown on the
f right hand side in this
screenshot).
Normal text file length:0 lines:1 Ln:1 Col:1 Sel:0|0 Dos\Windows ANSI INS J
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Configuring Notepad++

In the labs, certain commands and short-cut keys have been defined to make it easier for you to
compile and run your Python applications. This section will describe how to configure Notepad++ so
that the same commands and short-cut keys are available to you.

Display Font
To set the display font, go to:

Settings > Style Configurator...
Set Font to Courier New, and Font size to 12 for Language: Global Styles and Style: Global override

Select theme : | Default (stylers.xmi) -
Language : Style Global Styles : Global override
'ciobal Styles PN Giobal override IR
ActionScript Default Style Colour Style Font Style
ADA Indent guideline st
asp =| |Brace highiight styl Foreground D Font name :
Assembly Bad brace colour
autolt Current line backgl []Bold
bash Selected text colot| Fontsize: (12 v
Batch Caret colour Background I:l [Ctalic
c Edge colour ["Junderline
C+r Line number marg
c# Fold
Caml Fold active []Enable global font
ChtakeFile Fold margin [] Enable global foreground colour
cosoL White space symbr [Elenable global background colour L] Enable global font size
CoffeeScript Smart HighLighting
css Find Mark Style [Enable global bold font style
D Mark Style 1
o B I sg‘: ) e [|Enable global italic font style
[ Enable global underline font style

When you have finished, press 'Save and Close'.

NppExec Plugin

Open the Plugins menu. You will need an option called NppExec in this menu and it may not be

present by default (as in the example screenshot below): Plugns Window 2

There is no
Compare é_ NppExec
MIME Tools k appearing in
MppExport k this menu.
" Plugin Manager »
Spell-Checker  »

If the NppExec plugin is not present, you can enable it by going to Plugin Manager and selecting
Show Plugin Manager (If you still can't see the NppExec plugin look at the last two pages of this
document):

Plugins Window ?
Compare 4
MIME Tools »

MppExpart k

' Show Plugin Manager I

Spell-Checker  # About

DeEDN®E
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From here, find the NppExec plugin, and select it — then click Install:

/

Plugin Manager

Available I Updates | Installed |

Plugin / I Category | Available Version | Stability | :]
O multiClipboard Others 2.0 Good

[ Nativelang Others 1.2 Good

[ NppAutoIndeAt Others 1.2 Good

[ nppCrypt Others 1.0.0.4 Good

NppExec Others 0.3.3.1 Good

[ Npphethote Others 0.1 Good

[ oberon-2 Lexer Others 0.3 Good

[ Perforce actions Others 2.0.0.1 Good

[ Plugin Marker Margin Others 1.0 Good

[ Plugin update Others 0.3 Good |
With this NppExec plugin you can execute your commands or saved scripts without leaving Notepad ++. It makes Jou -
triple your productivity!

Author: Dovgan Vitaliy

Source: http: //downloads.sourceforge.net/project/npp-plugins/ J

Latest update: fix1: now CRLF (Enter key emulation) is sent to the pipe separately y ;]

s

You will be prompted to restart Notepad++. Click Yes, and wait for Notepad++ to restart.

You should now see NppExec appearing on the Plugins menu:

new 1- Notepads ——— [Ty

-
File Edit Search View Encoding Language ings Macro Run |Plugins | Window ? X
) B = | Rl el (ml (ol Gl (OeeXEX]

O EB IS4k > 0 % =|[0  DSpeliCheck » Dlialml o

= new 1 I MIME Tools » A _I f

Converter 4 g

1] A <
NppExec D Execute... F6
NppExport 4 Direct Execute Previous Ctrl+F6
NppFTP »| ¥ Show Console Dialog
Plugin Manager 4 Toggle Console Dialog Ctrl+~

Console Commands History
Console Output... {OEM/OEM}
No internal messages

Save all files on execute

Follow $(CURRENT_DIRECTORY)
Disable command aliases

<«

Console Output Filters... Shift+F6
Advanced Options...
Change Console Font...

Help/Manual
Help/Docs...
Help/About...

T

14\ ] ] »

Normal text file length:0 lines:1 Ln:1 Col:1 Sel:0]|0 Dos\Windows ANSI INS

Configure the NppExec Plugin:

Go to Plugins > NppExec and apply the followings
1. Enable "Show Console Dialog"
2. Enable "Save all files on execute"
3. Enable "Follow S(CURRENT_DIRECTORY)"
as shown in the screenshot above.
Short-cut keys
Define the function and the corresponding short-cut keys for running Python programs:
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1. Go to Plugins > NppExec > Execute...

2. Choose "Cancel" if a Save File... dialog box appears — probably will not happen
3. Enter the following command in the window:

as shown below:

-~

Execute... fWE wTw @Y - N u

Command(s):

cd "$(CURRENT_DIRECTORY)"
C:\Python34\Python "$(FULL_CURRENT_PATH)'|

-

e /]'[ oK ] [ Save... l ’ Cancel ]

Then choose Save... and, using the name "Run Python", save this script (see below):

/

Execute

Commands)

of “$ OURRENT DIRECTORY)"
Co\Pyhendy Python "$FLE_NAME

Press OK.

e ————————
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5. Define the scripts for the short-cut keys:

Go to NppExec "Advance Options",

Plugins | Window ?
DSpellCheck »
MIME Tools »
Converter »
NppExec »
NppExport 4
NppFTP »
Plugin Manager 4

X
Ei@iaﬂ

NppF TP - Disconnected |
Al RRE-T IERdl
Execute...
Direct Execute Previous
Show Console Dialog
Toggle Console Dialog

Console Commands History
Console Output... {OEM/OEM}
No internal messages

Save all files on execute

Follow $(CURRENT_DIRECTORY)

Disable command aliases

Console Output Filters...
Advanced Options...
Change Console Font...
Help/Manual
Help/Docs...
Help/About...

and enable "Place to the Macros submenu".

Now select "Run Python" from under the "Associated script:" menu, and click the

NppExec Advanced Options J

Menu items *

Place to the Macros submenu

"Add/Modify" button.

p

NppExec Advanced Options -

- ()

Menu items *

v|Place to the Macros submenu

Advanced options

Execute this script when Notepad++ stans

]

(]

Menu item

Rem name

Associated script

* Assign shoricut keys using Settings: Shortcut
Mapper -> Plugin commands

Execute this script when Notepad++ exits

[Options]

HotKey

ToolbarBtn

[Console]

Visible (on start)

ShowHelp (on start)
SaveCmdHistory
CommentDelimiter
TexiColorNormal (RR GG BB)
TextColorEmor (RR GG BB)

| TextColorMessage (RR GG BB)

Delete | BackgroundColor (RR GG BB)

.

Fé

(Console ]

000000
A01010
208020
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You should see the "Run Python" script added in the "Menu items" box as shown
below:

T — [
NppExec Advanced Options _u

Menu items * Advanced options
Place to the Macros submenu Execute this scriptwhen Notepad++ starts:
Sun Python :: Run Python [ 'l

Execute this script when Notepad++ exits:

[ -

[Options]
HotKey F6 v
[Console]
Move up Move down Visible (on start)
* Assign shortcut keys using Settings: Shortcut ShowHelp (on star)
Mapper -> Plugin commands
SaveCmdHistory
Menu item
CommentDelimiter I
ltem name:
Run Python TextColorNormal (RR GG BB) 000000
Associated script TextColorError (RR GG BB) A01010
[Run Python '] TextColorMessage (RR GG BB) 208020
[ Add/Modify ] [ Delete J BackgroundColor (RR GG BB) 0

’ OK ] [ Cancel ]

Select OK — you will be shown a dialog box indicating the Notepad++ needs to restart.

NppExec Advanced Options l]

l “'§ Notepad++ must be restarted to apply some of the options

Select OK, close Notepad++, then open it again.
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6. Finally, set up the short-cut key mappings:

Go to Setting > Shortcut mapper:

ISemE] Macro Run Plugins Window
Preferences... @ '
Style Configurator...

> Shortcut Mapper...

IPV

Import ’

Edit Popup ContextMenu

and select the "Plugin commands" tab. Scroll down to find the scripts you defined:

Shortcut mapper W . — l
Main menu | Macrosl Run commands ” Plugin commands Scintilla commands

l Name ] Shortcut [
E Execute... F6
| 24| Direct Execute Previous Ctr+F6
E Show Console Dialog
E Toggle Console Dialog Ctrl+™

E Console Commands History
Console Output...

No internal messages

Save allfiles on execute

Follow $(CURRENT_DIRECTORY)
Disable command aliases
Console Output Filters... Shift+F6
Advanced Options...

Change Console Font...
Help/Manual

Help/Docs...

Help/About...

Run Python Ctr
Exportto RTF

Exportto HTML

Copy RTF to clipboard
Copy HTML to clipboard
Copy all formats to clipboard
Show NppFTP Window
Focus NppFTP Window
About NppFTP

Show Plugin Manager
About

glalalalalalzlslslzlalelslalslslelelelelelsls

Ll

Note that you may first have to remove Ctrl 1 shortcut from one of the commands in the
Main menu list of commands (the list on the left most menu).

e ———————
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Double-click the "Run Python" script name to bring up the "Shortcut" box. In this box,
you can enter the desired short cut for the " Run Python" script. Select CTRL+1 as

shown below:

Name :  Run Python
+ [Clswrr +

[CJAT

OK Cancel

and then click the "OK" button and close the window.

Testing the configuration of Notepad++

To test that the Notepad++ has been configured correctly, enter the following source code into the

editor:

print("Hello world!")

and save the file in some location on your disk (remember the file should have a .py extension):

C)\Usersafer023\Desktop\CompSci10152\ecture01\L01Code\HiWorld.py—HoTepad + + ==

File Edit Search View Encoding Language e acro Run Plugins Window 2 X
SRS (L EE ey 2 BRI EEENIEDEDN®GE|EE) >
H riwordpy | e
print ("Hello World") EARRELIE 5

Console

—

Dos\Windows ANSI INS

length:20 lines:1 Ln:1 Col:21 Sel:0]|0

You should now be able to use the short-cut keys (or you can select them from the "Macro" menu) to

run your program:

e
Page 9
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(ay pp——— - [———
& W“ Des p\CompSc1101$2\LectureOl\LOlCode\HnWorld py - Notepad++ E X

Eile Edit Search View Encoding Language Settings [Macro] Run Plugins Window 2

s EE D& M| D€ SstartRecording CREEYIE
= Hiworld.py l Stop Recording - Disconnected x|
i 3 Playback Ctrl+Shift+P | § 3 & @ | & >
1 print ("Hello World")
Save Current Recorded Macro... =
Run a Macro Multiple Times... —
hon"
Trim Trailing and save Alt+Shift+S

¢ 23\Desktc

Modify Shortcut/Delete Macro... C: \U sers

—®Run Python cri+1 | "HiWorlc

Process started >>>

Hello World
<<< Process finished. (Exit

- y

Python file length:20 lines:1 Ln:1 Col:21 Sel:0|0 Dos\Windows ANSI INS .

You should see the console pane appear with the output from the Python interpreter:

Des p\CompSci10152\LectureOl\LOlCode\HiWorId py - Notepad++

File Edit Search View Encoding Language Settings Macro Run Plugins Window 2

L Ll L Y R s‘ﬂ.DlDI@@EEeI- 2

B HiWorld.py l
1 print ("Hello World")

Console

NPP_EXEC: "Run Python"

CD: C:\Users\afer023\Desktc
Current directory: C:\Users
C:\Python33\Python "HiWorlc
Process started >>>

Hello World

<<< Process finished. (Exit
=== READY ====

J—————
length:20 lines:1 Ln:1 Col:21 Sel:0|0 Dos\Windows ANSI

(If your program doesn't run correctly see the next page of this document).
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1. Short-cut keys (page 5)
Please note that the script for running a Python program is:

cd "S(CURRENT_DIRECTORY)"
C:\Python34\Python "$(FULL_CURRENT_PATH)"

"C:\Python34\Python" is the path to the place in your system where Python.exe exists. If your
program doesn't run then check that this path is correct. How to check (see below).

Go to the folder in the C drive where your folder containing the Python interpreter is stored:

® XTI

{5 &Y= & » Computer » Local Disk (C) » -
~ T

Organize v

2, Documents

& Local Disk (C:)

. Open

-

Include in library ¥

Name

Program Files (x86)

ProgramData

=- 1 @

Date modified

23/06/2014 2:1
21/07/2014 34

-4 Music . .
- pictures | Intel 24/05/2014 5:3
i Vg MSOCache 23/05/2014 10 The folder
4 1aeos . =
| PerfLogs 14/07/2009 3:2| = (directory) in thlS
P Fil 31/05/2014 4:2 .
"\ Computer E - Program fles o screenshot is

named Python33

&9 DVD RW Drive (D
- afer023 (\\files.fo

‘ | . Python33 26/05/2014 955 _ <4 but yours may be
named Python34
or some other

Python 3 version.

v < ] »

Python33 Date modified: 26/05/2014 9:59 a.m.
File folder

Open this folder and you will find your python executable:

= python.exe

(Note that sometimes the executable starts with lower case 'p') If the path to your python.exe is
different to the one shown in these notes, then change the script accordingly:

cd "$(CURRENT_DIRECTORY)"
C:WHATEVER_YOUR_PATH_IS\Python "$(FULL_CURRENT_PATH)"

e
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2. NppExec Plugin (page 3)
This does not appear in the list of available plugins.
Go to your C drive, Program Files and find the Notepad++ folder:

. <« Local Disk (C:) » Program Files (x86) »
S — =

——

Organize v Include in library v Share with Burn  » = - 0
2
I R
. Favorites Name Date modified
M Desktop Mozilla Firefox 23/05/2014 10

Mozilla Maintenance Service 23/05/2014 10
MSBuild 14/07/2009 5:2

14 Downloads =

<» Recent Places

)

)

)

| Notepad++ < 505720

- Libraries L. PuTTY 23/05/2014 10
., Documents I QuickTime 23/05/2014 10
Q/ Music | Realtek 24/05/2014 5:3
=, Pictures I Reference Ascembhliec 14/07/2009 527
s - i >
i ) 43 items
4

.« Program Files (x86) » Notepad++ »
— ——— S—

—
Organize v Include in library ~ Share with ¥ Bun > v. j 0
=
%, Documents o Name Date modified * |
-4 Music
R | localization 23/05/2014 10| =
LTS | plugi 26/05/om8 2|
ugins < :
B videos | — -~
| themes 23/05/2014 10
| updater 26/05/2014 2:5
& Computer = e
| usermanual 23/05/2014 10

& Local Disk (C)

) | change.log 9/05/2014 4:3€
&9 DVD RW Drive (D )
X ‘2] config.model.xml 23/05/2014 10
& afer023 (\\files.fo - . i -
sl < [ I »

' 18 items
4

Look inside and find the NppExec folder. If this folder isn't there, download a copy from the Internet,
and continue with the instructions on page 3:

—
Organize ~ Include in library ~ Share with Burn > =~ 0 @
< Documents “  Name Date modified %
& Music
. | APIs 23/05/2014 10/
&, Pictures
) | Config 23/05/2014 10|=
B videos .
| disabled 23/05/2014 10/
| doc 26/05/2014 2:5!
& Computer = P
5 | NppExec < 7670572014 25
& Local Disk (C:)
) 4 DSpellCheck.dll 11/02/2014 1:3
9 DVD RW Drive (D
3 4/ mimeTools.dll 1/12/2013 12:3
& afer023 (\\files.fo o I
sall < I »
| ' 12 items
)
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