
COMPSCI 111 S2 C - Lecture 5  1 of 6 
 

Word Processing 
(Using Microsoft Word) 

 
A word processor allows you to create, view, edit, format, print and store text.  Most modern word 
processors have many advanced and Microsoft Word is no exception.  Some of these features are 
incredibly useful, while others are not.  We will look at some of the more common features here. 
 
Creating documents 
A new document can be created by choosing New from the File menu.  Once the document is created, 
you can enter new text by simply typing on the keyboard.  The position where the text appears is 
indicated by a cursor, and is known as the insertion point.  The cursor usually appears as an I-beam (a 
vertical line), which blinks.  Some word processors use a solid blinking rectangle or an underscore to 
represent the cursor.  The location of the cursor can be altered by clicking the mouse at a new position in 
the text, or by using the cursor keys (arrow keys).  When the text reaches the end of the page, it 
automatically continues on the next line.  This feature is known as word wrap, and does not occur in 
some text editors and typewriters, where the machine must be manually told to start a new line by hitting 
a carriage return key (enter key on some keyboards).  It is important to realise that Microsoft Word uses 
the return key to signify the end of a paragraph.  You should always allow the word processor to decide 
how to wrap words, using a carriage return only to signify the end of a paragraph of text.  
 
Viewing a documents 
A document contains content (text) and information about how to display the content (formatting 
information).  Using Microsoft Word, you have different choices about how to view your document.  
Normal view is used for all the usual word processing tasks, however it does not display the page exactly 
as it will appear when printed.  To view the document as it will be printed, you should choose Page 
Layout (Print Layout) from the View menu.  Viewing a document using Page Layout (Print Layout) 
is slower because the computer must calculate more information, so there may be delays while the screen 
updates.  It is more accurate, and must be used for any complex layout involving multiple columns, 
drawing or pictures, page breaks, headers, footers etc. 
 
In many cases it is difficult to tell how the page is actually formatted.  You cannot tell by looking at the 
screen whether the words have merely wrapped to the next line, or if the paragraph ends and a new 
paragraph begins on the following line.  It is also difficult to see how many spaces there are between 
words, or how many tabs have been used.  It would be useful to be able to view these formatting 
characters, and in most word processors there is an option to do exactly that.  To view these special 
characters, choose Options from the Tools menu.  In the View Tab, you can select which non-printing 
characters to display on screen. 
 

 
Select All.  Notice how hidden characters become visible.  These non-printing characters will not be 
printed, whether you can see them on screen or not.  Being visible on screen just makes the job of 
formatting easier, without altering the printed page. 
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Editing a document 
The act of modifying or changing the content of your document is known as editing.  Some programs 
(known as text editors) provide the tools to edit text, but provide no way of printing, altering layout, 
changing presentation or formatting a document.  The most common editing features are explained 
below. 
 
 
Inserting and deleting text.   
Text can be inserted by placing the insertion point (cursor) at the place desired and simply typing on the 
keyboard.  Deleting text can be achieved by using the backspace key or the delete key (on extended 
keyboards).  The backspace key deletes the character to the left of the cursor, the delete key removes the 
character to the right of the cursor.  On the Macintosh keyboard, the backspace key is usually called 
delete, and the delete key is called del.  To remove a large block of text, select the text to remove (by 
dragging the mouse) and then press backspace or delete. 
 
Find and Replace. 
If you need to find a word in a document, then you can use the Find command from the Edit menu.  To 
replace the word with an alternative, you should use the Replace option (again from the Edit menu). 
 
This replace command can be extremely valuable if you need to make major changes to a document.  If 
you select the More button, you will be given more options, including the ability to search and replace 
special characters such as tabs, paragraph markers (i.e. return key), formatting styles and more. 

 
The Clipboard 
The clipboard is used to cut, copy and paste pieces of text from one position to another.  Remember that 
the clipboard can only keep one clipping at a time, so if you copy more than one piece of text, only the 
most recent text is retained for pasting. 
 
Spelling, Thesaurus, Grammar Checker 
These tools are provided to help authors produce more professional documents.  Some word processors 
automatically check the spelling and grammar as words are typed.  Any words spelt incorrectly are 
underlined in red (this red colour is not printed, but used only to alert the author of a problem).  Words 
can be added to the users personal dictionary to expand the number of words the computer can recognise 
(such as proper names or technical terminology).   
 
A recent feature added to many word processors is the ability to auto-correct words.  The computer 
maintains a list of words that should be changed to other words.  This feature helps correct any mistakes 
the author makes (since you can have a misspelling being changed to a correct spelling), and also allows 
them to use acronyms or shorthand which is automatically expanded by the computer (example:  you 
could get the computer to convert csd to computer science department).  When the user types any of the 
words, they are automatically changed to the correct version 
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Formatting Documents 
Once the text in a document is correct, the 
presentation may need to be altered.  In a 
word processor, the presentation is known 
as the format of the information.  Many 
aspects of a document may be altered to 
provide a wide range of presentation 
options.  The formatting toolbar provides 
many of these options which can be 
applied to the current selection with a 
single click.  However, more detailed 
options are usually found in the Format 
menu.  The most commonly used 
formatting options are detailed below.. 
 
Font 
The font describes the typeface and type 
size which are used to display text.  The 
font can usually be displayed in normal, 
bold, italic or underlined form.  Each 
individual character in a document may be 
displayed using different combinations of 
font formatting.  All the options can be 
altered by choosing Font from the Format 
menu. 
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Paragraph 
You are able to alter the spacing between 
lines in a document, or alter the alignment 
(left aligned, right aligned, justified, or 
centered) of a paragraph of text.  These 
options may be accessed by choosing 
Paragraph from the Format menu. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Document 
The Page Setup option from the File 
menu allows you to alter formatting which 
affects the entire document.  The margins 
and overall layout may be altered here.  
You can also set the location for the 
header and footer to appear. 
 
 
 
 
 
 
 
 
 
 
 
 
Columns 
Choosing Columns from the Format menu 
allows you to select the number of columns 
to use for displaying the text. 



COMPSCI 111 S2 C - Lecture 5  5 of 6 
 

Page and Section breaks 
Page breaks are used to finish a page at a particular 
point.  Any text after that point will be displayed on the 
following page.  To break the page, place the cursor 
where you wish to end the page, and choose Break 
from the Insert menu. 
  
A section break is used if you want to divide the 
document up into different sections.  Each section can 
use different formatting for margins, tab settings, header 
and footer, and number of columns.  A section break is 
invisible unless you are showing all the non-printing 
characters. 
 
Header and Footer 
To alter the contents of the header and footer, choose Header and Footer from the View menu.  The 
header appears at the top of every page, while the footer appears at the bottom of every page. 
 
Once you are viewing the Header and Footer, simply type the text inside the box.  A special toolbar will 
appear allowing you to insert text commonly used in headers and footers (such as date, page number 
etc.). 
 
 
 
 
 
 
 
 
Footnotes 
You can add footnotes to your document by placing the 
cursor in the desired position and choose Footnote 
from the Insert menu.  A reference mark (a small 
number) will appear at the position of the cursor, and 
you will be required to enter your footnote text which 
will appear at the bottom of the page.  To delete the 
footnote, you must delete the reference mark in the 
body of text.  Note that you are given an option to enter 
an endnote or footnote when you select Footnote from 
the Insert menu. 
 
 
 
 
 
 
 
Borders and Shading 
You can place a border around paragraphs of 
text, or around every page in the entire 
document.  Choose Borders and Shading 
from the Format menu. 
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User Defined Styles 
A list of common styles are provided in 
the Style pull-down menu on the 
formatting toolbar. 
 
These styles allow you to apply many 
formatting changes at the same time.  
Instead of altering the typeface to 
Times, then changing the size to 14 
point, then making the text bold, the 
entire style of the text can be altered at 
once by choosing the appropriate style 
from the style menu.  Of course, there 
must be an existing style with all the 
appropriate formatting before you can 
select it.  Some common styles are 
already created, but if none of these are 
suitable, you can create your own style.  
You are able to create new styles or 
modify existing ones by choosing Style 
from the Format menu. 
 
To create a new style, click on the New button.  You can enter a name for the new style, which will be 
used to refer to it in the Style menu on the Formatting toolbar.  Make sure you choose a sensible name for 
your style.  A style can be of two types:  Paragraph or Character.  A paragraph style applies to the 
entire paragraph.  A character style can be applied to individual characters within a paragraph.  If you 
want the entire paragraph to use the same formatting (e.g. font style, margins) then create a paragraph 
style, but if you want to apply the style to individual words, then it should be a character style.  By 
selecting the Format pull-down menu, you can create the style so that it contains the formatting you 
desire. 
 
When you have finished creating the style, it is added to the Style menu.  To apply the style, select the 
text to alter, then choose the appropriate style from the menu.  All the formatting of the text will change 
to that used by the style. 
 
If you have formatted the document using the styles, then you will find it easier to alter later.  For 
example:  if you decide that the style used for Headings is too small, then simply modify the format of 
that style (the Headings style).  All the text formatted according to the style will change when you modify 
the style definition.  You can make many changes at once using this method, saving much time and effort 
and ensuring that the document is consistently formatted.  It is easy to try a few different styles of 
presentation for your work, without having to carefully alter every piece of text. 
 
Printing Documents 
You can use Print Preview from the File menu to see what the document will look like when it is printed.  
Make sure you check the Page Setup to make sure the paper size is correct. 
 
Storing Documents 
All word processors will be able to understand plain text, since they all understand ASCII.  However, to 
display the different methods of presentation (e.g. bold, italic, font typeface, style, margins), the word 
processor needs to encode the information.  If another program uses a different method of encoding, the 
document will not be able to be understood.  Whenever you save a document, make sure you are aware 
of the Format the information is saved in.  In the Save Dialog box, you will see an option to Save as 
Type….  The default is the type that the application uses (such as Microsoft Word document), but most 
programs are able to translate the file format into a form understood by some other applications.  This can 
be useful if you are trying to use the information on another computer system. 
 
 
 

Author:  Andrew Luxton 
 


