Notepad++

The COMPSCI 101 Text Editor for Windows

The text editor that we will be using in the Computer Science

labs for creating our Java programs is called Notepad++ and is  http://notepad-plus.sourceforge.net
freely available for the Windows operating system. If you plan

to do work outside of the labs, perhaps at home, you may like

to use the same software that we have available in the labs. This document describes how to install and
configure Notepad++ using the same settings available in the labs.

What is a text editor?

A text editor is a program that enables you to write plain text files (a text file is a file that consists of lines
of text comprised mainly of the characters that you can type on a keyboard). A common extension for
text files is .txt, although the Java source files that we are creating in this course are also examples of
text files and use the extension .java. There are many text editors that are freely available for you to
use. For example, Windows provides a very simple text editor called Notepad (that you can find under
the Accessories menu). However, this is not a very good editor for writing source code because it
doesn’t support useful features such as syntax-colouring, auto-indentation and brace highlighting.
Notepad++ is a freely available text editor for Windows, and is the editor we will be using in the labs to
write our Java source code.

Install Java (JDK)

Before installing and configuring Notepad++ make Oveniew  Technologies D fon Community_Support [CRT
sure that you have msta”ed the Java Development Latest Release | Next Release (Early Access) | Embedded Use | Real-Time | Previous Releases
Kit (JDK). You can download and install the most

DEVELOPER.COM 2008
‘ PRODUCT OF THE YEAR

recent version from: Elavahx | | g Nothems || = Javakt
http://java .sun .Com/javase/down IoadS/index.jSp :aJEKPlﬁtLEn (JDK)  JDK+JavaFX Bundle  JDK +NetBeans Bundle JDK +Java EE Bundle
Here are the Java SE downloads in detail.
Make sure you are able to compile and run
. JDK 6 Update 18 (JDK or JRE) wnoa
p rogra m S u SI ng the CO mm a n d P rom pt bEfo re you This relea:e :'K:Tudes pe_rforr::rEmprovements and support for newer el
. . releases of these operating systems: Ubuntu, SuSe Linux, and Red Hat Docs ¥
install and configure Notepad++. Linux. » Leam more
What Java Do | Need? You must have a copy of the JRE (Java Runtime

Environment) on your system to run Java applications and applets. To develop
Java applications and applets, you need the JDK (Java Development Kit), which
includes the JRE.

NOTE: The Firefox 3.6 browser requires Java SE 6 Update 10 or later. Otherwise,
Java-based web will not work

Docs v
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Installing Notepad++

Go to the Resources page of the CompSci 101 website:
http://www.cs.auckland.ac.nz/courses/compscilOlslc/resources/

and download the zip file, Notepad++.zip, to your desktop.

The University of Auckland - COMPSCI 101 S1 C - Resources

<« @ /l‘ @ http://www.cs.auckland.ac.nz/courses /compscil01s1c/resources/ v | ([G]* Google Q) 3
Getting Started  Latest Headliness Requester Console (N... CECIL - The Universi.. NetAccount Admin
€ Human Resources - Staff - Th... @ | @ The University of Auckland - C... @
® Debugging

® Tracing Code
® Classes - a Card Class
= Complete Assignment Examples
Notepad++
The following zip file can be downloaded, unzipped and used to install Notepad++ on your computer.

L Notepad+; .zip

"Open command window here" powertoy

You can obtain the powertoy for opening a command window at the currently open window here:
http://www.microsoft.com/windowsxp/downloads/powertoys/xppowertoys.mspx 4

Unzip the file and you should see the following folder on your desktop:

File Edit Yiew > &

Name
I)Files
Finstall.cmd
Ninpp.5.6.7.Installer.exe

Right-click the installer.exe file and and select "run as administrator". Notepad++ will now be installed
on your computer.

»

To check that you have installed Notepad++ correctly, run the application (a link should appear
on your desktop) and you should see an editor window like the following appear:
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-loix]
File Edit Search View Encoding Language Settings Macro Run TextFX Plugins Window 2 X
Jo'JEE s o | & MM e || 2 s |EBEE|S1]: >
= new 1 I

|0 chars Obytes 1 |Ln :1 Col:1 Sel:0 (0bytes)in 0ranges |Dos\W|ndows |ANSI INS

Configuring Notepad++

In the labs, certain commands and short-cut keys have been defined to make it easier for you to compile
and run your Java applications. This section will describe how to configure Notepad++ so that the same
commands and short-cut keys are available to you.

Display Font
If you would like to set the display font to be identical to the settings used in the labs, go to:

Settings > Style Configurator...
Set Font to Courier, and Font size to 12 for Language: Global Styles and Style: Global override

Style Configurator |
L2 Sad o2 SR De fault (styles.xml) =
Language : Style : Global Styles : Global override
Global Styles PN Global override -
ActionScript Default Style | Colour Style Font Style
ADA Indent guideline sty
asp Brace highlight style Foreground colour l:l Font name : ICourier ;j
Assembly Bad brace colour
gutzlt Culrrentdline bad|<gr- I~ Bold
asl Selected text colou X Fontsize: |12 +
Batch Caret colour PRI - I™ Italic
C Edge colour ™ Underline
C++ Line number margin
C# Fold |
Caml Fold margin L e [~ Enable global font
CMakeFile White space symbo r ble clobal font
ggSéOL ﬁmsrr;H'ahsLt's:‘"”g I” Enable global background colour Enaic 9 ntsize
ind Marl e
D Mark Style 1 [~ Enable global bold font style
DIFF Mark Style 2 i
GUI4CL LI Mark Style 3 LI ™ Enable global italic font style
[~ Enable global underline font style
Cancel I Transparency
J—

NppExec Plugin

Open the Plugins menu. You will need an option called NppExec in this menu and it may not be present
by default (as in the example screenshot below):
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Plugins Window ?
Compare
MIME Tools
NppExport
Plugin Manager
Spell-Checker

v v Vv v v

If the NppExec plugin is not present, you can enable it by going to Plugin Manager and selecting Show
Plugin Manager:

Plugins Window ?

Compare ’\j‘@@@@@

MIME Tools »

NppExport »
' Show Plugin Manager
Spell-Checker »  About

From here, find the NppExec plugin, and select it — then click Install:

Plugin Manager

Available I Updates | Installed I

Plugin / | category | Available Version | Stabiity | N
O multiclipboard Others 2.0 Good

[ nativelang Others 1.2 Good

[ nNppAutoInde Others 1.2 Good

O nppcCrypt Others 1.0.0.4 Good

NppExec

[ nNpphethote Others 0.1 Good

[ oberon-2 Lexer Others 0.3 Good

[ Perforce actions Others 2.0.0.1 Good

[ Plugin Marker Margin Others 1.0 Good

[ Plugin update Others 0.3 Good |
With this NppExec plugin you can execute your commands or saved scripts without leaving Notepad ++. It makes you -
triple your productivity!

Author: Dovgan Vitaliy

Source: http://downloads.sourceforge.net/project/npp-plugins/

Latest update: fix1: now CRLF (Enter key emulation) is sent to the pipe separately ﬂ

You will be prompted to restart Notepad++. Click Yes and wait for Notepad++ to restart.

You should now see NppExec appearing on the Plugins menu:

e ——
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Configure the NppExec Plugin:
Go to Plugins > NppExec and apply the followings

1. Disable "Console Command History"
2. Enable "Save all files on execute"
3. Enable "Follow S(CURRENT_DIRECTORY)"

as shown in the screenshot below:

E =lol x|
X

Run TextFX | Plugins Window ?

2 | % = | Compare > b | (o] B
Light Explorer  »
MIME Tools »
Breae... rs
NppExport » Direct Execute Previous Ctrl+F6
NppNetNote »  Show Console Dialog
Plugin Manager »  Toggle Console Dialog Ctrl+~
Spell-Checker  » )
Console Commands History

Console Output... {OEM/OEM}
No internal messages

v Save all files on execute

v Follow $(CURRENT_DIRECTORY)
Disable command aliases

Console Output Filters... Shift+F6
Advanced Options...
Change Console Font...

[Dos\Windows ~ [ANST

Help/Manual
Help/About...

Short-cut keys
Define functions and corresponding short-cut keys for compiling and running Java programs:

1. Go to Plugins > NppExec > Execute...
2. Choose “Cancel” if a Save File... dialog box appears

3. Enter the following command:

cd “$(CURRENT_DIRECTORY)”
javac $(FILE_NAME)

as shown below:

e —
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Command(s):

X|

cd "$(CURRENT_DIRECTORY)"
javac S(FILE_NAME)

il

|<tJemporary script> j | oK I Save... |

=

s
Cancel |

Then choose Save... and save this using the name “Compile”:

Execute x|
Command(s):
cd "$(CURRENT_DIRECTORY)" 3

javac $(FILE_NAME)

—Script name:

I Compile Zl

Save Delete | Cancel | I SEVE, . I

vi

Cancel |

4. Save two more commands:
One called “Run”:

cd $(CURRENT_DIRECTORY)
java $(NAME_PART)

x|
Command(s):
cd "$(CURRENT_DIRECTORY)" N

java $(NAME_PART)

K

IRun
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and another called “Compile and Run”

cd S(CURRENT_DIRECTORY)
javac S(FILE_NAME)
java $(NAME_PART)

x

Command(s):

cd "$(CURRENT_DIRECTORY)" _‘_l
javac $(FILE_NAME)
java $(NAME_PART)

4 o

|Compile and Run

5. Define the scripts for the short-cut keys:

Go to NppExec Advance Options

=10l x|
Run TextFX | Plugins Window ? X
g| % = | Compare 3 (=l O
Light Explorer  »
MIME Tools »
NppExec 4 Execute... F&
————  NppExport »  Direct Execute Previous Ctrl+F6
_ NppNethNote ~ » v Show Console Dialog
T PlugnManager » Toggle Console Dialog Ctrl+~
SEEREIEET Console Commands History
Console Output... {OEM/OEM}
No internal messages
v Save all files on execute
v Follow $(CURRENT_DIRECTORY)
Disable command aliases
Console Output Filters... Shift+F6
[ Advarced optons |
B Change Console Font...
|pos\windows ~ |ANSI
Help/Manual
Help/About...

and enable "Place to the Macros submenu".
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NppExec Advanced Options

Menu items *
[V Place to the Macros submenu:

Then select “Compile” from under the “Associated script:” menu, and click the
“Add/Modify” button:

x
—Menu tems * — Advanced options |
[V Place to the Macros submenu Execute this script when Notepad++ starts:
Compile :: Compile I ﬂ
Execute this script when Notepad++ exits:
| =
— [Options]
HotKey Fé v
ToolbarBtn IConsole = I
~ [Console]
tove up Move down Visible (on start) m
* Assign shortcut keys using Settings: I :]
Shortcut Mapper -> Plugin commands LRIt No =
SaveCmdHistory Yes =
— Menu item
Comment Delimiter I//
ltem name: I
Icompﬂe TextColorNormal (RR GG BB) IOO 00 00
Associated script: TextColorEmor (RR GG BB) IAO 1010
| Compile ~| | | TextColorMessage (RR GG BB) 208020
Delete BackgroundColor (RR GG BB) IO
ok | cancel

You should see the script added in the “Menu items” box as shown above.

Repeat this process for the other two scripts, be careful to type the names “Run” and
“Compile and Run” in the “Item name:” box before hitting the Add/Modify button.

The screenshot below shows what this should look like when you have added all three
scripts:
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NppExec Advanced Options X|

—Menu items * — Advanced options ]
[V Place to the Macros submenu Execute this script when Notepad++ starts:
Compile :: Compile | LI
Run :: Run L )
Compile and Run :: Compile and Run Execute this script when Notepad++ exits:
~ [Options]
HotKey F6 v
ToolbarBtn IConsoIe v I
~[Console]
Move up Move down Visible (on start) mo -
* Assign shortcut keys using Settings: l_j'
Shortcut Mapper -> Plugin commands LI Bl No
SaveCmdHistory Yes i
—Menu item
Comment Delimiter I//
ltem name:
ICompiIe and Run TextColorNomal (RR GG BB) IOD 00 00
Associated script: TextColorEmor (RR GG BB) IAO 1010
v TextColorMessage (RRGG BE)  [208020
Add/Modify | Delete | BackgroundColor (RR GG BB) IO

| OK I Cancel

Select OK — you will be shown a dialog box indicating the Notepad++ needs to restart.
x

l } Notepad++ must be restarted to apply some of the options

Select OK, and close Notepad++, then open it again.
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6. Finally, set up the short-cut key mappings:

Go to Setting > Shortcut mapper:

Language | Settings Macro Run TextFX Plugins

0| preferences.. B
Style Configurator...
Import »

and select the “Plugin commands” tab. Scroll down to find the scripts you defined:

Shortcut mapper x|
Main menu I Macros I Run commands ” Plugin commands = Sdintilla commands |

Name || Shortcut |;|

Change Console Font...
Help/Manual
Help/About..

_ [
compite [ |
Run
Compile and Run
Exportto RTF
Exportto HTML
Copy RTF to clipboard
Copy HTML to clipboard
Copy all formats to clipboard
Show Dialog
ETEXTEX NULL FUNCTION
Convertquotesto "

Convertquotesto'

Swap quotes (" <->")

Drop quotes " &'

Escape "to\"

Escape 'to\'

Escape 'to\" |

L e e P P P P P N P N N N P P Y

Double-click the “Compile” script name to bring up the “Shortcut” box. In this box, you
can enter the desired short cut for the “Compile” script. Enter CTRL+1 as shown below:

R —
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Shortcut X

Name : I Compile

Vv CTRL

+ T osarr + | ~

[~ AT

| OK I Cancel |

Repeat this for the other two scripts so that you have defined:

Compile: Ctrl+1
Run: Ctrl + 2
Compile and Run: Ctrl + 3

Shortcut mapper x|
Main menu I Macros | Run commands ” Plugin commands = Sdintilla commands I

Name H Shortcut I:l
Change Console Font...
Help/Manual
Help/About...

[

Compile Ctrl+1
Run Ctrl+2
Exportto RTF

Exportto HTML

Copy RTF to clipboard

Copy HTML to clipboard

Copy all formats to clipboard

Show Dialog

LTEXTEXNULL FUNCTION

Convertquotes to "

Convertquotesto'

Swap quotes (" <->")

Drop quotes " &'

Escape "to\"
Escape 'to'
Escape 'to\" |

lalslalelolelalalalzlsls s lelalelzllelelels)

and then click the “Close” button

Output Font
To set the font for the output window, go to Plugins > NppExec > Change Console Font, and set to
Courier font, and Font size to 12
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Testing the configuration of Notepad++

To test that the Notepad++ has been configured correctly, enter the following source code into the
editor:

public class Test {

public static void main (String[] args) {
System.out.println ("Hello world!");

and save the file in some location on your disk:

EC:\Users\pauI\Desktop\Test.java - Notepad++ o ] 2|
File Edit Search View Encoding Language Settings Macro Run TextFX Plugins Window 2 X
J cHHE s ial4sOD|2e |t 2 s (BHE(ZIEDOENDBE=ay
[=| Testjava I

1 public class Test {

2 public static void main(String[] args) {

3 System.out.println("Hello world!"™);

4 }

5 }

6
[3a\[104 chars 114bytes 6lines n:6 Col:1 Sel:0 (0bytes)in0ranges [Dos\Windows  |ANST NS

You should now be able to use the short-cut keys (or you can select them from the “Macro” menu) to
compile and run your program:

h - Notepad++

anguage Settings | Macro Run TextFX Plugins Window ?

1| @ @  StrtRecording (o] [ o] |
Stop Recording
Flayback Chrl+5hift+P
{ Saye Current Recorded Macra,..,
void main (S| Run a Macro Multiple Times...
t.println("H Trim Traiing and save Alt+Shift+5
Compile Ctrl+1 I
Run Ctrl+2
Compile and Run Ctrl+3

e ——
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You should see the console pane appear with output from the compiler:

E C:\Users\paul\Desktop\Test.java - Notepad++ = |D|z|
X

File Edit Search View Encoding Language Settings Macro Run TextFX Plugins Window 2
| cHE 5 c@|dDM[oe (|| £t s|EBEE%1FEOIENRE=ay »
ET&javaI

public class Test {
public static void main(String[] args) {

N

2 System.out.println("Hello world!");
4 }

S }

6

NPP_EXEC: "Compile™

CD: C:\Users\paul\Desktop

Current directory: C:\Users\paul\Desktop
javac Test.java

Process started >>>

<<< Process finished.

READY =====

[32\[104 chars 114bytes 6 lines lln:6 Col:1 Sel:0(0bytes)in 0ranges [pos\windows  [ANST sy

You can then run the program:

Settings | Macro Run TextFX Plugins Window ?

| @ €  StartRecording o] [m] |
Stop Recording
layback CErl+Shift+P
Save Current Recorded Macra, .,

Run a Macro Multiple Times...

)

main (S
ntin ("2 Trim Traiing and save Alt+Shift+5
Compile Ctrl+1

Run Ctrl+2
Compile and Run Ctrl+3

and you should see the output appear in the console window:

[ Console

NPP_EXEC: "Run”

CD: C:\Users\paul\Desktop

Current directory: C:\Users\paul\Desktop
java Test

Process started >>>

Hello world!

< << Process finished.

R ——
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